about summary refs log tree commit diff
path: root/home/profiles/messaging/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/messaging/default.nix')
-rw-r--r--home/profiles/messaging/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/home/profiles/messaging/default.nix b/home/profiles/messaging/default.nix
index 14b31a1..d0978a0 100644
--- a/home/profiles/messaging/default.nix
+++ b/home/profiles/messaging/default.nix
@@ -12,7 +12,6 @@ let
       key = lib.elemAt x' 1;
       action = lib.last x';
     });
-  mailPass = x: if pkgs.stdenv.isLinux then "${pkgs.pass}/bin/pass show emails/${x}" else "";
   mbsyncCmd = if pkgs.stdenv.isLinux then "${config.programs.mbsync.package}/bin/mbsync" else "";
 in
 {
@@ -25,6 +24,9 @@ in
 
   config = lib.mkIf cfg.enable (lib.mkMerge [
     (lib.mkIf pkgs.stdenv.isLinux {
+
+      sops.secrets.sef-imap-password = { };
+
       accounts.email = {
         maildirBasePath = "${config.home.homeDirectory}/mail";
 
@@ -74,7 +76,7 @@ in
           primary = true;
           realName = "***REMOVED***";
           userName = poorObfuscation "sefidel.com" "contact";
-          passwordCommand = mailPass "sef";
+          passwordCommand = "cat ${config.sops.secrets.sef-imap-password.path}";
         };
 
         accounts.zach = {