about summary refs log tree commit diff
path: root/hydra/jobsets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hydra/jobsets.nix')
-rw-r--r--hydra/jobsets.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/hydra/jobsets.nix b/hydra/jobsets.nix
new file mode 100644
index 0000000..07c0fab
--- /dev/null
+++ b/hydra/jobsets.nix
@@ -0,0 +1,34 @@
+{ nixpkgs, ... }:
+
+let
+  pkgs = import nixpkgs {};
+
+  jobsets = {
+    main = {
+      enabled = 1;
+      hidden = false;
+      description = "main branch";
+      nixexprinput = "nixrc";
+      nixexprpath = "hydra/default.nix";
+      checkinterval = 300;
+      schedulingshares = 100;
+      enableemail = false;
+      emailoverride = "";
+      keepnr = 1;
+      inputs = {
+        nixrc = {
+          type = "git";
+          value = "https://git.exotic.sh/pub/sefidel/nixrc main";
+          emailresponsible = false;
+        };
+        nixpkgs = {
+          type = "git";
+          value = "https://github.com/NixOS/nixpkgs.git nixos-unstable";
+          emailresponsible = false;
+        };
+      };
+    };
+  };
+in {
+  jobsets = pkgs.writeText "jobsets.json" (builtins.toJSON jobsets);
+}