about summary refs log tree commit diff
path: root/lib/mk_home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mk_home.nix')
-rw-r--r--lib/mk_home.nix27
1 files changed, 1 insertions, 26 deletions
diff --git a/lib/mk_home.nix b/lib/mk_home.nix
index 899be0f..925fdbe 100644
--- a/lib/mk_home.nix
+++ b/lib/mk_home.nix
@@ -15,34 +15,9 @@ let
 
     home = {
       inherit username;
-      homeDirectory = if pkgs.stdenv.isDarwin then "/Users/${username}" else "/home/${username}";
+      homeDirectory = "/home/${username}";
       stateVersion = version;
     };
-
-    # Make applications pop up in finder/spotlight
-    disabledModules = [ "targets/darwin/linkapps.nix" ];
-    home.activation = lib.mkIf pkgs.stdenv.isDarwin {
-      copyApplications =
-        let
-          apps = pkgs.buildEnv {
-            name = "home-manager-applications";
-            paths = config.home.packages;
-            pathsToLink = "/Applications";
-          };
-        in
-        lib.hm.dag.entryAfter [ "writeBoundary" ] ''
-          baseDir="$HOME/Applications/Home Manager Apps"
-          if [ -d "$baseDir" ]; then
-            rm -rf "$baseDir"
-          fi
-          mkdir -p "$baseDir"
-          for appFile in ${apps}/Applications/*; do
-            target="$baseDir/$(basename "$appFile")"
-            $DRY_RUN_CMD cp ''${VERBOSE_ARG:+-v} -fHRL "$appFile" "$baseDir"
-            $DRY_RUN_CMD chmod ''${VERBOSE_ARG:+-v} -R +w "$target"
-          done
-        '';
-    };
   };
 in
 home-manager.lib.homeManagerConfiguration {