about summary refs log tree commit diff
path: root/modules/binary-cache/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/binary-cache/default.nix')
-rw-r--r--modules/binary-cache/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/binary-cache/default.nix b/modules/binary-cache/default.nix
new file mode 100644
index 0000000..9dd55b5
--- /dev/null
+++ b/modules/binary-cache/default.nix
@@ -0,0 +1,13 @@
+{ config, pkgs, lib, ... }:
+let
+  folder = ./caches;
+  toImport = name: value: folder + ("/" + name);
+  filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
+  imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
+in
+{
+  inherit imports;
+  nix.settings.substituters = [ "https://cache.nixos.org/" ];
+
+  environment.systemPackages = [ pkgs.cachix ];
+}