about summary refs log tree commit diff
path: root/modules/flakes.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/flakes.nix')
-rw-r--r--modules/flakes.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/modules/flakes.nix b/modules/flakes.nix
index 76f89f3..092d1f4 100644
--- a/modules/flakes.nix
+++ b/modules/flakes.nix
@@ -1,10 +1,10 @@
-{ config, pkgs, unstable, unstable-small, nixpkgs-2211, lib, ... }:
+{ config, pkgs, unstable, unstable-small, nixpkgs-2305, lib, ... }:
 
 let
   base = "/etc/nixpkgs/channels";
   nixpkgsPath = "${base}/nixpkgs";
   nixpkgsSmallPath = "${base}/nixpkgsSmall";
-  nixpkgs2211Path = "${base}/nixpkgs2211";
+  nixpkgs2305Path = "${base}/nixpkgs2305";
 in
 {
   options.nix.flakes.enable = lib.mkEnableOption "nix flakes";
@@ -16,12 +16,12 @@ in
 
       registry.nixpkgs.flake = unstable;
       registry.nixpkgsSmall.flake = unstable-small;
-      registry.nixpkgs2211.flake = nixpkgs-2211;
+      registry.nixpkgs2305.flake = nixpkgs-2305;
 
       nixPath = [
         "nixpkgs=${nixpkgsPath}"
         "nixpkgsSmall=${nixpkgsSmallPath}"
-        "nixpkgs2211=${nixpkgs2211Path}"
+        "nixpkgs2305=${nixpkgs2305Path}"
         "/nix/var/nix/profiles/per-user/root/channels"
       ];
     };
@@ -29,7 +29,7 @@ in
     systemd.tmpfiles.rules = [
       "L+ ${nixpkgsPath}         - - - - ${unstable}"
       "L+ ${nixpkgsSmallPath} - - - - ${unstable-small}"
-      "L+ ${nixpkgs2211Path} - - - - ${nixpkgs-2211}"
+      "L+ ${nixpkgs2305Path} - - - - ${nixpkgs-2305}"
     ];
   };
 }