about summary refs log tree commit diff
path: root/modules/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nix.nix')
-rw-r--r--modules/nix.nix17
1 files changed, 4 insertions, 13 deletions
diff --git a/modules/nix.nix b/modules/nix.nix
index 8396739..37c9fe5 100644
--- a/modules/nix.nix
+++ b/modules/nix.nix
@@ -1,8 +1,5 @@
 { config, lib, ... }:
 
-let
-  allowed = config.nix.allowedUnfree;
-in
 {
   options.nix = {
     experimentalFeatures = lib.mkOption {
@@ -12,19 +9,13 @@ in
         Enables experimental features
       '';
     };
-
-    allowedUnfree = lib.mkOption {
-      type = lib.types.listOf lib.types.str;
-      default = [ ];
-      description = ''
-        Allows for  unfree packages by their name.
-      '';
-    };
   };
 
   config = lib.mkMerge [
-    (lib.mkIf (config.nix.experimentalFeatures != "") { nix.extraOptions = "experimental-features = ${config.nix.experimentalFeatures}"; })
-    (lib.mkIf (allowed != [ ]) { nixpkgs.config.allowUnfreePredicate = (pkg: __elem (lib.getName pkg) allowed); })
+    (lib.mkIf
+      (config.nix.experimentalFeatures != "")
+      { nix.extraOptions = "experimental-features = ${config.nix.experimentalFeatures}"; })
+
     { nix.settings.auto-optimise-store = lib.mkDefault true; }
     {
       nix.gc.automatic = lib.mkDefault true;