about summary refs log tree commit diff
path: root/modules/services/nitter.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/nitter.nix')
-rw-r--r--modules/services/nitter.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/services/nitter.nix b/modules/services/nitter.nix
new file mode 100644
index 0000000..81fcd3e
--- /dev/null
+++ b/modules/services/nitter.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+let
+  cfg = config.modules.services.nitter;
+in
+{
+  options.modules.services.nitter = {
+    enable = mkEnableOption "nitter instance";
+
+    title = mkOption { type = types.str; default = "Nitter"; description = "Title of the nitter instance"; };
+
+    domain = mkOption { type = types.str; };
+    realHost = mkOption { type = types.str; default = "nitter.${cfg.domain}"; };
+    secrets = {
+      nitter-guest-accounts = mkOption { type = types.path; description = "path to the JSONL file containing guest accounts"; };
+    };
+  };
+
+  config = mkIf cfg.enable {
+    services.nitter = {
+      enable = true;
+
+      server = {
+        title = cfg.title;
+        address = "127.0.0.1";
+        port = 4002;
+        hostname = cfg.realHost;
+      };
+      guestAccounts = cfg.secrets.nitter-guest-accounts;
+    };
+  };
+}