about summary refs log tree commit diff
path: root/nixos/alpha/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/alpha/configuration.nix')
-rw-r--r--nixos/alpha/configuration.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/alpha/configuration.nix b/nixos/alpha/configuration.nix
index bf9b7e1..e259f33 100644
--- a/nixos/alpha/configuration.nix
+++ b/nixos/alpha/configuration.nix
@@ -221,10 +221,16 @@
     ];
   };
 
+  users.mutableUsers = false;
+
+  fileSystems."/persist".neededForBoot = true;
+
   users.users = {
+    root.passwordFile = "/persist/passwords/root";
     zach = {
       isNormalUser = true;
       shell = pkgs.zsh;
+      passwordFile = "/persist/passwords/zach";
 
       extraGroups = [
         "wheel"