about summary refs log tree commit diff
path: root/nixos/alpha/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/alpha/configuration.nix')
-rw-r--r--nixos/alpha/configuration.nix34
1 files changed, 16 insertions, 18 deletions
diff --git a/nixos/alpha/configuration.nix b/nixos/alpha/configuration.nix
index d9dd00d..332c25a 100644
--- a/nixos/alpha/configuration.nix
+++ b/nixos/alpha/configuration.nix
@@ -22,7 +22,7 @@
     };
   };
 
-  boot.kernelPackages = pkgs.linuxPackages_6_0;
+  boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
   boot.kernelParams = [
     "nohibernate"
     "nmi_watchdog=0"
@@ -67,22 +67,20 @@
 
   i18n.defaultLocale = "en_US.UTF-8";
   i18n.inputMethod.enabled = "kime";
-  i18n.inputMethod.kime.config = {
-    engine = {
-      global_hotkeys = {
-        C-Space = {
-          behavior = {
-            Toggle = [ "Hangul" "Latin" ];
-          };
-          result = "Consume";
-        };
-        AltR = {
-          behavior = "Ignore";
-          result = "Bypass";
-        };
-      };
-    };
-  };
+  i18n.inputMethod.kime.extraConfig = ''
+    engine:
+      global_hotkeys:
+        C-Space:
+          behavior: !Toggle
+          - Hangul
+          - Latin
+          result: Consume
+        AltR:
+          behavior: !Ignore
+          - Hangul
+          - Latin
+          result: Bypass
+  '';
 
   console.font = "${pkgs.dina-font}/share/fonts/misc/DinaMedium10.pcf.gz";
   console.colors = [
@@ -114,7 +112,7 @@
   services.zfs.autoScrub.pools = [ "rpool" ];
 
   services.openssh.enable = true;
-  services.openssh.passwordAuthentication = false;
+  services.openssh.settings.passwordAuthentication = false;
   services.openssh.hostKeys = [
     {
       path = "/persist/ssh/ssh_host_ed25519_key";