about summary refs log tree commit diff
path: root/nixos/alpha/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/alpha/hardware-configuration.nix')
-rw-r--r--nixos/alpha/hardware-configuration.nix33
1 files changed, 12 insertions, 21 deletions
diff --git a/nixos/alpha/hardware-configuration.nix b/nixos/alpha/hardware-configuration.nix
index 0749482..eebe49a 100644
--- a/nixos/alpha/hardware-configuration.nix
+++ b/nixos/alpha/hardware-configuration.nix
@@ -5,60 +5,51 @@
 
 {
   imports =
-    [
-      (modulesPath + "/installer/scan/not-detected.nix")
+    [ (modulesPath + "/installer/scan/not-detected.nix")
     ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
+  boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ "kvm-amd" ];
   boot.extraModulePackages = [ ];
 
   fileSystems."/" =
-    {
-      device = "rpool/local/root";
+    { device = "rpool/local/root";
       fsType = "zfs";
     };
 
   fileSystems."/boot" =
-    {
-      device = "/dev/disk/by-uuid/C5C1-09F1";
+    { device = "/dev/disk/by-uuid/12CE-A600";
       fsType = "vfat";
     };
 
   fileSystems."/nix" =
-    {
-      device = "rpool/local/nix";
+    { device = "rpool/local/nix";
       fsType = "zfs";
     };
 
   fileSystems."/home" =
-    {
-      device = "rpool/safe/home";
+    { device = "rpool/safe/home";
       fsType = "zfs";
     };
 
   fileSystems."/persist" =
-    {
-      device = "rpool/safe/persist";
+    { device = "rpool/safe/persist";
       fsType = "zfs";
     };
 
-  #  fileSystems."/mnt/resident" =
-  #    {
-  #      device = "/dev/disk/by-uuid/fe7a00a8-0a3c-48de-9d7a-ed7cf172f501";
-  #      fsType = "ext4";
-  #    };
-
   swapDevices =
-    [{ device = "/dev/disk/by-uuid/4f06a42c-c4cc-4861-8ae0-dcff81d719d3"; }];
+    [ { device = "/dev/disk/by-uuid/ce1b717c-9a99-4357-8784-48435afe3826"; }
+    ];
 
   # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
   # (the default) this is the recommended approach. When using systemd-networkd it's
   # still possible to use this option, but it's recommended to use it in conjunction
   # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
   networking.useDHCP = lib.mkDefault true;
-  # networking.interfaces.enp4s0.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp14s0.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp16s0u3u4u3c2.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp15s0.useDHCP = lib.mkDefault true;
 
   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
   hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;