about summary refs log tree commit diff
path: root/nixos/cobalt/services/akkoma.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/cobalt/services/akkoma.nix')
-rw-r--r--nixos/cobalt/services/akkoma.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/nixos/cobalt/services/akkoma.nix b/nixos/cobalt/services/akkoma.nix
index 7164b3f..c01689a 100644
--- a/nixos/cobalt/services/akkoma.nix
+++ b/nixos/cobalt/services/akkoma.nix
@@ -3,15 +3,21 @@
 let
   poorObfuscation = y: x: "${x}@${y}";
   federation-blocklist = lib.importTOML ./akkoma-assets/blocklist.toml;
+
+  # ifd3f/infra
+  wrapFile = name: path:
+    (pkgs.runCommand name { inherit path; } ''
+      cp -r "$path" "$out"
+    '');
 in
 {
   services.akkoma = {
     enable = true;
     initDb.enable = true;
 
-    # extraStatic = {
-    #   "favicon.png" =
-    # };
+    extraStatic = {
+      "static/logo.png" = wrapFile "logo.png" ./akkoma-assets/logo.png;
+    };
     config = let inherit ((pkgs.formats.elixirConf { }).lib) mkRaw mkMap;
     in {
       ":pleroma"."Pleroma.Web.Endpoint".url.host = "social.sefidel.com";
@@ -27,6 +33,11 @@ in
 
         limit = 5000;
       };
+      ":pleroma".":frontend_configurations" = {
+        pleroma_fe = mkMap {
+          logo = "/static/logo.png";
+        };
+      };
       ":pleroma".":mrf" = {
         policies = map mkRaw [ "Pleroma.Web.ActivityPub.MRF.SimplePolicy" ];
       };