about summary refs log tree commit diff
path: root/nixos/cobalt/services/soju.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/cobalt/services/soju.nix')
-rw-r--r--nixos/cobalt/services/soju.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/nixos/cobalt/services/soju.nix b/nixos/cobalt/services/soju.nix
deleted file mode 100644
index bab8a5b..0000000
--- a/nixos/cobalt/services/soju.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ config, ... }:
-
-{
-  services.soju = {
-    enable = true;
-    extraGroups = [ "acme" ];
-    hostName = "cobalt.sefidel.com";
-    listen = [
-      ":6697"
-    ];
-    tlsCertificate = "${config.security.acme.certs."sefidel.com".directory}/cert.pem";
-    tlsCertificateKey = "${config.security.acme.certs."sefidel.com".directory}/key.pem";
-  };
-
-  networking.firewall.allowedTCPPorts = [ 6697 ];
-
-  environment.persistence."/persist".directories = [
-    "/var/lib/private/soju"
-  ];
-
-  # TODO: remove this once merged
-  disabledModules = [ "services/networking/soju.nix" ];
-
-  imports = [
-    ./acme.nix
-    ../modules/soju.nix
-  ];
-}