about summary refs log tree commit diff
path: root/nixos/colmena.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/colmena.nix')
-rw-r--r--nixos/colmena.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/nixos/colmena.nix b/nixos/colmena.nix
new file mode 100644
index 0000000..99945e6
--- /dev/null
+++ b/nixos/colmena.nix
@@ -0,0 +1,28 @@
+{ self, unstable, unstable-small, ... } @ inputs:
+
+{
+  meta = {
+    nixpkgs = import unstable {
+      system = "x86_64-linux";
+    };
+  };
+
+  defaults = { pkgs, ... }: {
+    environment.systemPackages = with pkgs; [
+      curl
+      vim
+    ];
+  };
+
+  cobalt = self.lib.mkColmena {
+    name = "cobalt";
+    system = "x86_64-linux";
+    inputs = inputs;
+    deployment = {
+      targetHost = "cobalt.sefidel.com";
+      targetPort = 22;
+      targetUser = "root";
+    };
+    time.timeZone = "UTC";
+  };
+}