about summary refs log tree commit diff
path: root/nixos/configurations/hardware/alpha.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/hardware/alpha.nix')
-rw-r--r--nixos/configurations/hardware/alpha.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/nixos/configurations/hardware/alpha.nix b/nixos/configurations/hardware/alpha.nix
deleted file mode 100644
index 3e99ea9..0000000
--- a/nixos/configurations/hardware/alpha.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-let
-  espDev = "/dev/disk/by-uuid/7905-2E41";
-  btrfsDev = "/dev/disk/by-uuid/dc47a0a6-3c73-45c1-951c-40032e762180";
-  swapDev = "/dev/disk/by-uuid/4a74b247-99e9-42c7-9a86-75aea964bb85";
-  dataDev = "/dev/disk/by-uuid/fe7a00a8-0a3c-48de-9d7a-ed7cf172f501";
-
-  subvolume = name: {
-    device = btrfsDev;
-    fsType = "btrfs";
-    options = [ "subvol=${name}" "compress=zstd" "noatime" ];
-  };
-in
-{
-  boot.initrd.availableKernelModules = [ "xhci-pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-amd" "tcp_bbr" ];
-  boot.extraModulePackages = [ ];
-
-  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-  hardware.enableRedistributableFirmware = true;
-
-  fileSystems."/" = subvolume "root";
-  fileSystems."/home" = subvolume "home";
-  fileSystems."/nix" = subvolume "nix";
-  fileSystems."/persist" = subvolume "persist";
-  fileSystems."/var/log" = {
-    device = btrfsDev;
-    fsType = "btrfs";
-    options = [ "subvol=log" "compress=zstd" "noatime" ];
-    neededForBoot = true;
-  };
-
-  fileSystems."/boot" = {
-    device = espDev;
-    fsType = "vfat";
-  };
-
-  fileSystems."/data" = {
-    device = dataDev;
-    fsType = "ext4";
-  };
-
-  swapDevices = [{ device = swapDev; }];
-
-  nix.maxJobs = lib.mkDefault 4;
-  powerManagement.cpuFreqGovernor = lib.mkDefault "schedutil";
-}