about summary refs log tree commit diff
path: root/nixos/kanata/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/kanata/configuration.nix')
-rw-r--r--nixos/kanata/configuration.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/kanata/configuration.nix b/nixos/kanata/configuration.nix
index b927a86..dbf7c29 100644
--- a/nixos/kanata/configuration.nix
+++ b/nixos/kanata/configuration.nix
@@ -104,6 +104,7 @@ in
   # TODO: insecure?
   sops.secrets.invidious-hmac = { mode = "0444"; };
   sops.secrets.transmission-extra-config = { owner = "transmission"; };
+  sops.secrets.paperless-superuser-password = { owner = "paperless"; };
 
   boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
   boot.kernel.sysctl."net.ipv6.conf.all.forwarding" = 1;
@@ -158,6 +159,7 @@ in
         "hydra.kusanari.network".to = "http://localhost:4004";
         "cache.kusanari.network".to = "http://localhost:4005";
         "torrent.kusanari.network".to = "http://localhost:4006";
+        "paperless.kusanari.network".to = "http://localhost:4007";
 
         # Nginx pre-configured routes
         "nextcloud.kusanari.network" = {
@@ -195,6 +197,7 @@ in
             "hydra"
             "cache"
             "torrent"
+            "paperless"
           ];
         };
       };
@@ -272,6 +275,13 @@ in
 
       secrets.transmission-extra-config = config.sops.secrets.transmission-extra-config.path;
     };
+
+    services.paperless = {
+      enable = true;
+
+      realHost = "paperless.kusanari.network";
+      secrets.paperless-superuser-password = config.sops.secrets.paperless-superuser-password.path;
+    };
   };
 
   containers.v-interlink = {