about summary refs log tree commit diff
path: root/nixos/kompakt/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/kompakt/configuration.nix')
-rw-r--r--nixos/kompakt/configuration.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/kompakt/configuration.nix b/nixos/kompakt/configuration.nix
index 716ceb5..e318ebc 100644
--- a/nixos/kompakt/configuration.nix
+++ b/nixos/kompakt/configuration.nix
@@ -48,6 +48,16 @@
 
   sound.enable = true;
 
+  # Backlight control
+  programs.light.enable = true;
+  services.actkbd = {
+    enable = true;
+    bindings = [
+      { keys = [ 224 ]; events = [ "key" ]; command = "/run/current-system/sw/bin/light -U 10"; }
+      { keys = [ 225 ]; events = [ "key" ]; command = "/run/current-system/sw/bin/light -A 10"; }
+    ];
+  };
+
   fonts = {
     fontDir.enable = true;