about summary refs log tree commit diff
path: root/nixos/modules/ec2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/ec2.nix')
-rw-r--r--nixos/modules/ec2.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/modules/ec2.nix b/nixos/modules/ec2.nix
new file mode 100644
index 0000000..45f3cd8
--- /dev/null
+++ b/nixos/modules/ec2.nix
@@ -0,0 +1,9 @@
+{ modulesPath, config, lib, ... }:
+
+{
+  # AWS EC2-specific tweaks
+  imports = [
+    "${modulesPath}/virtualisation/amazon-image.nix"
+  ];
+  ec2.hvm = true;
+}