about summary refs log tree commit diff
path: root/nixos/modules/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/nix.nix')
-rw-r--r--nixos/modules/nix.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/nixos/modules/nix.nix b/nixos/modules/nix.nix
deleted file mode 100644
index 8396739..0000000
--- a/nixos/modules/nix.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, lib, ... }:
-
-let
-  allowed = config.nix.allowedUnfree;
-in
-{
-  options.nix = {
-    experimentalFeatures = lib.mkOption {
-      type = lib.types.separatedString " ";
-      default = "";
-      description = ''
-        Enables experimental features
-      '';
-    };
-
-    allowedUnfree = lib.mkOption {
-      type = lib.types.listOf lib.types.str;
-      default = [ ];
-      description = ''
-        Allows for  unfree packages by their name.
-      '';
-    };
-  };
-
-  config = lib.mkMerge [
-    (lib.mkIf (config.nix.experimentalFeatures != "") { nix.extraOptions = "experimental-features = ${config.nix.experimentalFeatures}"; })
-    (lib.mkIf (allowed != [ ]) { nixpkgs.config.allowUnfreePredicate = (pkg: __elem (lib.getName pkg) allowed); })
-    { nix.settings.auto-optimise-store = lib.mkDefault true; }
-    {
-      nix.gc.automatic = lib.mkDefault true;
-      nix.gc.options = lib.mkDefault "--delete-older-than 10d";
-    }
-  ];
-}