about summary refs log tree commit diff
path: root/modules/sops.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 13:29:27 +0900
committersefidel <contact@sefidel.net>2024-01-24 18:59:54 +0900
commit8e9b074467006c76768efe04cf1fb1ef9d652c67 (patch)
treefad73c7f94a74c77714c260d1fc0a63e2d205b49 /modules/sops.nix
downloadinfra-modules-8e9b074467006c76768efe04cf1fb1ef9d652c67.tar.gz
infra-modules-8e9b074467006c76768efe04cf1fb1ef9d652c67.zip
initial commit HEAD main
Diffstat (limited to 'modules/sops.nix')
-rw-r--r--modules/sops.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/sops.nix b/modules/sops.nix
new file mode 100644
index 0000000..2b6cdef
--- /dev/null
+++ b/modules/sops.nix
@@ -0,0 +1,19 @@
+{ config, lib, inputs, ... }:
+
+with lib;
+let
+  cfg = config.modules.sops;
+in
+{
+  imports = [ inputs.sops-nix.nixosModules.sops ];
+
+  options.modules.sops = {
+    enable = mkEnableOption "sops secret manager";
+
+    secretsDir = mkOption { type = lib.types.path; };
+  };
+
+  config = mkIf cfg.enable {
+    sops.defaultSopsFile = "${cfg.secretsDir}/secrets.yaml";
+  };
+}