about summary refs log tree commit diff
path: root/modules/sops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/sops.nix')
-rw-r--r--modules/sops.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/sops.nix b/modules/sops.nix
new file mode 100644
index 0000000..2b6cdef
--- /dev/null
+++ b/modules/sops.nix
@@ -0,0 +1,19 @@
+{ config, lib, inputs, ... }:
+
+with lib;
+let
+  cfg = config.modules.sops;
+in
+{
+  imports = [ inputs.sops-nix.nixosModules.sops ];
+
+  options.modules.sops = {
+    enable = mkEnableOption "sops secret manager";
+
+    secretsDir = mkOption { type = lib.types.path; };
+  };
+
+  config = mkIf cfg.enable {
+    sops.defaultSopsFile = "${cfg.secretsDir}/secrets.yaml";
+  };
+}