about summary refs log tree commit diff
path: root/modules/services/ldap.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
committersefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
commit813a4f4340849b407eaa9d03f65fbe8f3e716bf2 (patch)
tree6af83c5bdc887accc01e1f3ed4f6e1a53d7d8d0b /modules/services/ldap.nix
parent38b45cd6d6caffb6c32ed8720b3174f25354f965 (diff)
downloadinfra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.tar.gz
infra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.zip
feat(modules): use types.path for secret paths
Diffstat (limited to 'modules/services/ldap.nix')
-rw-r--r--modules/services/ldap.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/ldap.nix b/modules/services/ldap.nix
index 7c4724f..e75d739 100644
--- a/modules/services/ldap.nix
+++ b/modules/services/ldap.nix
@@ -11,7 +11,7 @@ in
     dc = mkOption { type = types.str; };
     tld = mkOption { type = types.str; };
     tls.acmeHost = mkOption { type = types.str; default = "${cfg.dc}.${cfg.tld}"; };
-    secrets.rootPass = mkOption { type = types.str; description = "path to the root password file"; };
+    secrets.rootPass = mkOption { type = types.path; description = "path to the root password file"; };
   };
 
   config = mkIf cfg.enable {