about summary refs log tree commit diff
path: root/modules/services/ldap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/ldap.nix')
-rw-r--r--modules/services/ldap.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/ldap.nix b/modules/services/ldap.nix
index 7c4724f..e75d739 100644
--- a/modules/services/ldap.nix
+++ b/modules/services/ldap.nix
@@ -11,7 +11,7 @@ in
     dc = mkOption { type = types.str; };
     tld = mkOption { type = types.str; };
     tls.acmeHost = mkOption { type = types.str; default = "${cfg.dc}.${cfg.tld}"; };
-    secrets.rootPass = mkOption { type = types.str; description = "path to the root password file"; };
+    secrets.rootPass = mkOption { type = types.path; description = "path to the root password file"; };
   };
 
   config = mkIf cfg.enable {