about summary refs log tree commit diff
path: root/modules/services/metrics.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
committersefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
commit813a4f4340849b407eaa9d03f65fbe8f3e716bf2 (patch)
tree6af83c5bdc887accc01e1f3ed4f6e1a53d7d8d0b /modules/services/metrics.nix
parent38b45cd6d6caffb6c32ed8720b3174f25354f965 (diff)
downloadinfra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.tar.gz
infra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.zip
feat(modules): use types.path for secret paths
Diffstat (limited to 'modules/services/metrics.nix')
-rw-r--r--modules/services/metrics.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/metrics.nix b/modules/services/metrics.nix
index b06a401..5f03389 100644
--- a/modules/services/metrics.nix
+++ b/modules/services/metrics.nix
@@ -9,7 +9,7 @@ in
     enable = mkEnableOption "metrics";
     domain = mkOption { type = types.str; };
     tls.acmeHost = mkOption { type = types.str; default = cfg.domain; };
-    secrets.adminPassword = mkOption { type = types.str; description = "path to the admin password"; };
+    secrets.adminPassword = mkOption { type = types.path; description = "path to the admin password"; };
   };
 
   config = mkIf cfg.enable {