about summary refs log tree commit diff
path: root/modules/services/metrics.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/metrics.nix')
-rw-r--r--modules/services/metrics.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/metrics.nix b/modules/services/metrics.nix
index b06a401..5f03389 100644
--- a/modules/services/metrics.nix
+++ b/modules/services/metrics.nix
@@ -9,7 +9,7 @@ in
     enable = mkEnableOption "metrics";
     domain = mkOption { type = types.str; };
     tls.acmeHost = mkOption { type = types.str; default = cfg.domain; };
-    secrets.adminPassword = mkOption { type = types.str; description = "path to the admin password"; };
+    secrets.adminPassword = mkOption { type = types.path; description = "path to the admin password"; };
   };
 
   config = mkIf cfg.enable {