about summary refs log tree commit diff
path: root/home/modules/profiles/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
committersefidel <contact@sefidel.net>2022-01-18 17:38:31 +0900
commit7a372ed81256ce5d6aa608be9bebe173ab4e042e (patch)
tree29c7ee0a316ae0dc21ce3fe22342ec2c36ee0f4c /home/modules/profiles/default.nix
parent2bdc141bebd35cc38396271c42b23b6f89d032a0 (diff)
downloadnixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.tar.gz
nixrc-7a372ed81256ce5d6aa608be9bebe173ab4e042e.zip
project: rewrite
Diffstat (limited to 'home/modules/profiles/default.nix')
-rw-r--r--home/modules/profiles/default.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/home/modules/profiles/default.nix b/home/modules/profiles/default.nix
deleted file mode 100644
index af9d9a8..0000000
--- a/home/modules/profiles/default.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-{ config, lib, ... }:
-let
-  profileEnabler =
-    let
-      reducer = l: r: { "${r}".enable = true; } // l;
-    in
-    builtins.foldl' reducer { } config.activeProfiles;
-in
-{
-  options.activeProfiles = lib.mkOption { type = lib.types.listOf lib.types.str; };
-
-  config.profiles = profileEnabler;
-}