about summary refs log tree commit diff
path: root/home/modules/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/default.nix')
-rw-r--r--home/modules/profiles/default.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/home/modules/profiles/default.nix b/home/modules/profiles/default.nix
deleted file mode 100644
index af9d9a8..0000000
--- a/home/modules/profiles/default.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-{ config, lib, ... }:
-let
-  profileEnabler =
-    let
-      reducer = l: r: { "${r}".enable = true; } // l;
-    in
-    builtins.foldl' reducer { } config.activeProfiles;
-in
-{
-  options.activeProfiles = lib.mkOption { type = lib.types.listOf lib.types.str; };
-
-  config.profiles = profileEnabler;
-}