about summary refs log tree commit diff
path: root/home/profiles/base/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-01-17 12:49:16 +0900
committersefidel <contact@sefidel.net>2023-01-17 12:49:16 +0900
commit33f9503104aa816d147a006a7ca68b03fbc7f1eb (patch)
tree95780ec05190db7e99814678cc7ec8ef4d445b87 /home/profiles/base/default.nix
parent900a5105509c7523dc2c5d034bca6871862206ce (diff)
downloadnixrc-33f9503104aa816d147a006a7ca68b03fbc7f1eb.tar.gz
nixrc-33f9503104aa816d147a006a7ca68b03fbc7f1eb.zip
feat(darwin,nixos): use overlay for neovim
Diffstat (limited to 'home/profiles/base/default.nix')
-rw-r--r--home/profiles/base/default.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/home/profiles/base/default.nix b/home/profiles/base/default.nix
index fdd524c..e1e895e 100644
--- a/home/profiles/base/default.nix
+++ b/home/profiles/base/default.nix
@@ -3,8 +3,6 @@ let
   cfg = config.profiles.base;
 
   neotheme = config.neotheme;
-
-  inherit (self.packages.x86_64-linux) neovim;
 in
 {
   imports = [
@@ -96,8 +94,7 @@ in
       pkgs.procs
       pkgs.sops
       pkgs.tree
-      # Don't manage neovim
-      neovim
+      pkgs.neovim
 
       # Common build tools
       (pkgs.rust-bin.selectLatestNightlyWith (toolchain: toolchain.default))